SalesLogix Upgrade

Release Notes
SalesLogix Version 6.0 Resolved Issues

The following issues have been fixed in SalesLogix version 6.0.

Administrator
1-6184
The state of the close button (the "X" next to the minimize button) is inconsistent. It changes between active and
grayed when you move between the following views: Users, System, Teams, Library, DBManager, Bundler, Admin
Roles.
1-9484
On the Systems>Offices tab in the SalesLogix Administrator, the last column should read “Library Path” instead of
“Sales Library Path”.
10000
The USERCOMPANY field must be added to the USERINFO table so the name of the company that the user works
for is in the database. This will allow the user to add the company name to their signature.
1-10003
Once the "Insert" / "Note" item in Menu Security is disabled, a user should not be able to add a note from the
History tab in the SalesLogix Client. This functionality should be disabled.
1-10526
The International Setting located in the SalesLogix Administrator > Options > System Settings > Names > Styles is
intended to parse the last 2 words of a name to the last name. For example, Jerry von Bebber would be stored with
the last name "von Bebber". It currently behaves as the U.S. setting.
1-15817
When the path of the Library Folder is changed in the Administrator, the change is not available to the Network
Client users by solely refreshing the Administrator. You must close, and then open the Administrator to see that
path does reflect the change.
1-9045
When creating a new table or field, if you change the table name or field name after the display name field has been
populated, the display name will not be updated with the new information.
4921
When installing a bundle, the button options include No to all, Yes, No, and All. This is inconsistent with other
Windows applications.

Advanced Outlook Integration
1-13409
If a user is using Outlook offline and they have previously been set up to use the SLX Address Book, after a timeout
period of 1 minute, the following error displays: "Database error: Unable to connect: SQL Server is unavailable or
does not exist". Then, the BDE connection dialog box opens so the user can select a different database, which has
to be cancelled before the user is allowed into Outlook. Adjusting the CONNECT_TIMEOUT is the only other way to
avoid the message, but this could cause other problems if it is adjusted. The same setting in Outlook could be used
or a new option for the timer could be added to the SalesLogix Address Book.
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1-13731
The Insert > SalesLogix Library, My vCard, and Contact vCard do not appear when Word is selected as the e-mail
editor in Outlook XP.
1-14527
In Outlook XP, with Word as the e-mail editor, the "Send Email" button populates the e-mail message with the text
of the history record incorrectly. All of the formatting is gone.
1-15094
If the SalesLogix Client is open with no view having focus (Contacts, Accounts, etc.), and the user clicks the "Add
contact(s) to Outlook" button, an exception error occurs.
1-15400
The SalesLogix Connector Login window does not have focus when it displays. A user must click on the window to
give it focus first instead of just being able to hit the "Enter" key when it displays.

Advanced Sales
1-15505
In SalesLogix versions prior to 5.2, the RMB menu choice for Show Graphical View for sales processes was
available in the data grid. If a process was not in focus, the menu choice was grayed out but it was still there. In
5.2, the menu item is not in the list unless the process tree is expanded, and the process in the tree is highlighted.
It is only then that the menu item is enabled both in the tree and the grid.
1-8831
When a user creates a new opportunity and adds a sales process, the Opp_SalesStep table does not update if the
user deletes the opportunity.
8869
Double clicking outside of the grid view produces an error within the Forecasting component.

Architect
10988
After making changes to a view, a dialog box appears prompting the user to save the changes. If the user chooses
not to save, they must click “No” three times in order to close the dialog box and exit Architect.
1-14775
SalesLogix function "IsPhone" is not working correctly in Basic Script.
15296
The 'Name Prefix' and the 'Name Suffix' pick lists sort alphabetically in the client even when the 'Sorted
alphabetically' check box is not selected.
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Communications
1-11467
A process that is setup to send an e-mail with an attachment will not attach the file when the message is sent
through the SalesLogix Mail Client
1-12793
When an e-mail is received in the SalesLogix Mail Client using GroupWise as the mail system, the following
message is received "Error: Could not fill the header: An invalid argument was passed in the function call."

Crystal Reports
1-14815
Crystal Report fails with a Contact group, where the condition of 'accountmanagerid = :USERID' is defined for the
group.
1-14884
When running the "Contact Detail" Crystal Report against a group that has two contacts with the same name, only
the first contact's detail information displays.
1-15101
When you try to print any of the 3 graphs that may be displayed at the end of the Crystal Report "Potential Sales
Opportunities" (when logged on as Lee), a number of error messages appear and the Sales Client closes. If you are
logged on as Admin, the graphs print correctly. Workaround: Within the Crystal Report Viewer, before printing the
graph for Lee, ensure the Print Setup is set to Landscape. This prevents the errors and the graph prints correctly.
1-20649
Our sample Crystal Reports are not consistent in the way they handle date and currency formatting.
Some reports convert date-time to string and others convert date-time to date-time. Currently, you cannot run
reports with date filters when your client and database server have different Regional Options. Date Time issues have
been addressed in 6.0 as follows: All sample reports have been converted to evaluate Date-Time fields as DateTimes. By doing this, we eliminate the inconsistencies associated with Date-Time strings.

1-6860
There are some Reporting parameters on the Web Client that do not match the LAN Client's Reporting parameters.
The items are listed below. The Operating System, Browser, and database platforms are not applicable.
Contact [CRW] Contact Detail - Sample - Everyone> View History Notes>> Not on Web
Account [CRW] Account Detail - Sample - Everyone> View Leadsource>> Not on Web
Account [CRW] Account Detail - Sample - Everyone> View History Notes>> Not on Web
Opportunity [CRW] Opportunity Summary - Sample - Everyone> Include History Notes>> LAN doesn't have this,
Web is also not working
History [CRW] History by Contact - Sample - Everyone> Start on a New Page>> LAN doesn't have this, Web is also
not working
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History [CRW] History Summary - Sample - Everyone> Start on a New Page>> LAN doesn't have this, Web is also
not working
History [CRW] History by Account - Sample - Everyone> Start on a New Page>> LAN doesn't have this, Web is
also not working
Activities [CRW] Literature Fulfillment Summary - Sample - Everyone> Fulfillment Status>> Web displays as TEXT
input field, key in a value does not work
Activities [CRW] Literature Fulfillment Details - Sample - Everyone> Fulfillment Status>> Web displays as TEXT
input field, key in a value does not work

Database
1-15452
The CONTACT_LEADSOURCE table was populated with invalid dates in the CREATEDATE and LEADDATE
columns. This causes the table and the UI to display the Delphi "incorrect date value" of 12/30/1899.
1-15908
Many of the e-mail domains in the Eval DB are valid domains. To avoid this, the ".com" for all of the e-mail
addresses in the CONTACT table need to be changed to ".demo".

Installs
1-8003
In the Add/Remove programs on a Windows 2000 machine, the icons that are associated with our installs are
incorrect. For example, the icon for the Administrator appears as the TranAnalyzer icon.
1-15498
The SalesLogix installation should autopopulate the install path if another SalesLogix product is detected.

Intellisync
1-19923
The Intellisync documentation should be updated to include the following about configuring Intellisync: Intellisync
cannot be configured to sync with Outlook when Outlook is in offline mode. When configuring Intellisync, Outlook
must be online. Once Intellisync has been successfully configured to sync with Outlook, Intellisync can be run with
Outlook either offline or online.

Mail Client
1-6500
When an Opportunity Detail view is opened in SalesLogix and a user sends an e-mail in the SalesLogix Mail Client,
a record of that e-mail is recorded in the Notes/History section of that Opportunity, even though the e-mail that was
sent has nothing to do with that Opportunity. This happens even if the SalesLogix Client is minimized.
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Marketing
1-16130
When a user creates a campaign and adds a contact response, a Basic error occurs when no Target Audience is
entered.

Remote Client
1-9570
New contacts are not showing up in the 'What's New' Contact tab.

Reports
1-76
SalesLogix Support Reports should contain filters like SalesLogix Sales.

Sales Client
10641
When the user opens the dialer, and then clicks on the Dialing Properties or Connections tab, the Personal and
Activity Pad buttons disappear, which is the correct functionality. But, if the user is currently on the Where to Dial
tab and chooses Tools>Connections or Tools>Dialing Properties the buttons should appear and do not.
1-10232
When user "A" assigns a contact process to user "B" and that contact process starts with a Question, user "A" is
the user prompted for the question, not user "B" to whom the process was assigned.
1-11319
Lookup results appear behind Calendar, Activities, Library, Reports and Process views.
1-14105
Processes that are setup to send an e-mail with a file attached, do not attach the file.
1-14861
If the Activity Alarm dialog box opens while the user is editing notes, and they select Snooze, the text added to the
note disappears.
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1-15119
Insert>File Attachment opens up the 'Select' view, allowing the user to choose a file to attach. Clicking the Cancel
button in this view should end the attachment process. However, cancelling this view opens up the Add Attachment
For: view.
1-16548
Calendar Reports does not display properly. The Overflow Page does not word wrap and the text is cut short at the
end of one line.
1-16888
The data grid in the new Notes/History view displays dates in a dd/Month/Yr <time> format. For example, 28-Nov2001 2:30 PM. This is inconsistent with dates as displayed in other parts of the client, and even in the longnotes
field of the same view. The standard is mm/dd/yy, so logically the date should display as Nov-28-2001 <time>.
1-17947
When a contact process containing a Word e-mail fails, a History record is written that doesn't indicate that the email failed (unlike in SalesLogix v4.1)
1-19729
The user that an Ad Hoc group is released to is unable to add a Contact to that group.
1-6897
The vertical scrollbar does not work correctly in list views. When there are more records than can be displayed in the
view and the vertical scroll bar is moved, it jumps back to its previous location. If it’s moved past the half way point, it
jumps to the half way point.
1-8931
A non-admin user cannot run Crystal Report 'Support Account List by Weight' from Sales Client.
1-9088
Activity Conflict message appears even though "Check Availability" is deselected in the Tools>Options>General Tab.
8093
On the Reports View, the reports are not sorted in alphabetical order (by report type and Name) within the tree.
Currently they display in the order they are stored in the database. A user should be able to add sort by report
name within type under each of the categories (Contact, Opportunity, Account etc...).
8437
When in the Activity Detail view, if no activity is selected, there is no prompt to select an activity.
8721
When in Contact, Account, or Opportunity list view and the user double clicks to "keep" the record found, and then
clicks OK, the list view disappears.
8963
When the X in the Exit Confirm view of the Activity Notepad scenario is clicked, both the Confirm view and the
Activity Note Pad view close.
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1-6780
In the Purge Wizard, if a user purges according to a value in a $ field, and uses a comma in this field, error
messages display. If a comma is not permissible, an informative message to that effect would be less alarming than
the error messages.

Services
1-14816
When the location of the SyncServices.cfg file is changed in the Administrator and the service remains on the same
machine, the registry entry for the location of the SyncServices.cfg file is not changed. It continues to use the old file
if it is available, or the service runs without any jobs running if the old file is not still available.

Support Client
1-11498
On the Call Turn-Around Analysis report, the Actual Time Open field is not calculating properly. It is calculating in
days but should be calculating in hours.
1-12116
On theTicket List view, the tickets are not listed in the correct numerical order. Also, when you select the Ticket ID
column heading, it does not sort properly.
1-14489
In the Ticket Detail view, when any tab is clicked it is not saving. For example, when a new ticket is created and a
user clicks the Contracts tab before clicking Save, the Contract does not appear in the data grid. The Ticket Detail
view should be saved when any of the tabs are selected.
1-14722
A program error appears after exiting the Support Client.
1-15180
In the Support Client, if a user has a contract with the "Begin Contract After First Ticket" checkbox selected, a
warning is received when making that contract the active contract on the Ticket detail window.
1-15583
When creating a new defect or editing a defect activity, and then changing the Received Date, the current date still
displays in the Defect Detail Activity tab view. If you open the activity, the date is correct, but it does not display
correctly on the Defect Detail Activity tab.
1-15689
On the Lookup Account Product window and the Lookuprmareceivedproduct window, you cannot search when you
type information in the search field. The search comes back empty. If you do not enter any information in the field
and search, information does appear. User should be able to enter information in the search field to narrow down the
search.
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1-15902
If an Account is deleted in the Sales Client or the Support Client, all Tickets tied to that Account are deleted too.
There should be some way to keep the Tickets as a history.
1-16305
A Runtime error appears when inserting a new ticket if the value in the hours field on the Urgency Alert dialog box is
larger than 540 hours.
1-17335
When a users does a lookup using a certain field, and then clears that field and uses a different field for the lookup,
the Support Client uses both fields to filter the results of the search. The Client should clear the field and only
search on the new data entered.
1-17710
The wording on the Default Owners Tab under User Options is not correct. It should read as follows: These settings
control who owns Accounts and Defects when they are first created by you.
1-17715
On the Tools>Manage>Auto Assignment window the Owner column label should be changed to Assigned To
because the value of that column is not the owner but the person assigned to that area.
1-17798
When a user creates a new contract, and then adds a product from the Product tab, the product does not display in
the data grid. If the user attempts to add the product again, it still does not display. If the window is closed, and then
opened the product will display (multiple times if it was added more than once). Pushing F5 will display the product
and any further products added will display when they are added.
16305
Ticket QBE labels are inconsistent with Ticket Edit view. The Ticket QBE fields Reported By & Reported Date fields
should be Received By & Received Date on the Ticket Edit view.
1-80
Ticket view > Urgency field has a pick list icon but brings up a Lookup. This is inconsistent with the rest of the
application.
1-8787
The Group Manager in the Support Client displays the Opportunity family. This should not appear since Support
does not use Opportunities.
1-8938
The Bundle Info button is missing from the Help About screen.
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Sync Server
1-12323
There needs to be a Sync Server specific Help that will get installed with the Sync Server. All Sync Server related
topics from the Administrator Help should be included in the Sync Server Help.
1-14814
If a user modifies the location of the SyncService.cfg file in the Administrator>Sync Automations Services tab, it
writes a new record to the SYNCSERVICEFILE table. Customers have reported that this sometimes causes the
SyncService to fail. If they delete the old row from the database, and then restart the service, it runs without a
problem.

Synchronization
1-14596
In the Monitor Console dialog box, the user should have right mouse functionality. It should only work when a
selected service is highlighted and it should contain all values from the File menu.
1-14597
In the Monitor Console, if there are two or more services being monitored, it always takes about ten seconds for the
second service to switch from red to green. All others turn green right away.

Ticket Activity
1-17741
When a user opens a ticket from the Account Detail view, and then looks up a different account's ticket using the
search on AlternateKeySuffix (Ticket ID in the view), makes changes to the second ticket, then saves the ticket by
closing it with the X, it appears incorrectly in the first account's ticket list.

Web Client

1-10018
Web> Add an Opportunity> Quantity field allows unlimited number of characters to be entered. After 14 characters,
the number rounds in the Enter Product Pricing view> Quantity field.
1-10022
Add a Note> Duration field> should not be able to have a duration that is less than 5 minutes on the noteadd1
template.
1-14822
When scheduling an activity and setting Every X Weeks, the Web Client ignores the number of weeks if more than
one day of the week is selected.
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1-14841
In the Event Edit view, the Reset button changes the Day Type field to "/blank" instead of the previously saved value.
1-14864
After an alternate address is added to the Contact or Account Addresses tabs, and the user returns to the tab view,
the alternate address does not display until the view is refreshed.
1-15390
Web Client> Calendar> Day & Week Views> Timeless Personal Activities do not display Contact/Account info (if
present).
1-17822
In the Template> Download Tools> SlxWordTools.dot, the macro for the SLXInsertFields is not 'installing'. This
happens when a virus macro checker, from a 3rd-Party product, is loaded on the environment. It strips the macro
from the SlxWordTools.dot.
1-17860
Web Client> Contact or Account> Address tab> Updating Primary and Mailing fields result in inconsistencies in
database. Positive values posts as 'T' and sometimes as 'Y' and negative values can post as 'F' or 'N'. Values
should post as 'T' or 'F'.
1-19215
Activity Manager does not display the correct count of overdue activities as it does on the SalesLogix Client. This
should be consistent between products.
1-19307
The Event time is posted incorrectly for a user who's day Start/End time is other than the 9AM-5PM default setting.
1-19312
When a user creates a note on the Contact or Account Detail view, focus is returned to the What's New view instead
of the Contact or Account Detail view from which it was created.
1-20591
When a user schedules a contact process in the Web Client, the Process Owner is written to the database as the
user logged in, not the user selected.
1-8039
On the Template Tools Download view, the information on step one regarding the Word Template location is not
correct. The location will vary by Operating System and the Microsoft Word version. The step should read:
1. Right-click SLXWordTools.dot, then select Save Target As SLXWordTools.dot in your Microsoft Word templates
folder. ***To find the default location, open Microsoft Word. On the [Tools] menu, select [Options]. On the [File
Locations] tab, select [User Templates], and click [Modify] to view the path. An example for Windows 2000/ Word
2000 is: C:\Documents & Settings\<userloginname>\Application Data\Microsoft\Templates***
1-8939
On the Web Client> Add an Opportunity> Step 2d > Product Summary > "Actual Close Date" field if the "Edit
Pricing" button is selected and the method is "Available Pricing Levels", and the user returns to the Product
Summary view, the Actual Close Date field is autopopulated with the current date and time.
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1-8943
Mail > 'Merge with' tab, clicking any of the 'Find' buttons will open a list view in the lower frame. If there has been an
Ad-Hoc Group in the tabs displayed and the user clicks this group, nothing will happen. The list stays on prior 'tab'
list. Mail Merge does not recognize the Ad-Hoc Groups.
1-8945
Add an Opportunity>"Close Probability" field allows numbers greater than 100. A message should display
immediately if invalid characters are entered stating that the "The close probability cannot be greater than 100%".
1-9199
Invalid times (Hour = 13-99 or Minute = 60-99) entered into the 'Edit an Activity' view display as 12:00AM and posts
to the database without a time in the STARTDATE field upon 'Update'. Other views edit and display an 'invalid start
time' error message and don’t post to the database.
1-9472
Web Client> Find a Product> Family and Group custom text fields blank out after 'Find' button is selected.

Web DLL
1-18515
Web DLL> Admin?Command> cacheon/cacheoff>> The 'cacheon' & 'cacheoff' administrative commands are
currently not working.

Web Manager
1-14442
SDK > Option Explicit is not working properly in the Web Client action.
1-8857
When creating a Web query, if the query has more than one Condition/Sorting set and you edit it too many times,
any additional Condition/Sorting sets seem to disappear.

Web Reports
1-15398
Web Client > Web Reports > Report Groups > Contacts>> Web and LAN queries differ.

WebTicket Employees
1-6586
WebTicket doesn't work properly when using international date settings such as dd/MM/yyyy.
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