Crystal Reports Professional XI R2 SP3 for SalesLogix 7.5.x Issue

 


The SalesLogix 7.5 Compatibility Checklist and Implemenation Guide say that  Crystal Reports Professional XI R2 needs to be upgraded to Service Pack 3 (SP3). Also, SP3 is provided on the Crystal installation DVD. However, when you try to install SP3 the below message appears and the installation stops.  


 


 


 


“Service Pack 2 is not detected. Requirements for SP3 install not met. Please install SP2 first.”  


 


 


 


 


You can download SP2 from Business Objects and install it first (be sure to download the full version, not the incremental version); however, according to Sage SalesLogix Support, SP3 is not needed. You can perform SalesLogix 7.5.x Crystal Reports maintenance with the supplied release level 2 (R2) of Crystal Reports XI Professional. (Defect 1-65743 addresses this issue.)  


 


 


 


This SP3 information only relates to Crystal Reports Professional. Crystal Reports Embedded Server installation does require SP3, and the SP3 provided on the DVD does not require the installation of any earlier service packs.  

Submit a Comment

Your email address will not be published. Required fields are marked *

Subscribe To Our Newsletter

Join our mailing list to receive the latest Infor CRM (Saleslogix) and Creatio (bpm'online) news and product updates!

You have Successfully Subscribed!